Skip to content

1z0-066 Oracle Database 12c: Data Guard Administration Practice Questions

Prepare for 1z0-066 with more than an answer.

112 questions in the full set12 sample questionsUpdated Sep 16, 2021
Exam fee
$245 USD
Time limit
150 minutes
Questions on the exam
92
Passing score
61% (scale 0-100%)
Level
Oracle Certified Expert (OCE)
Valid for
Certification does not expire, but recertification recommended for newer versions
  1. 1

    Which three are true about disabling of the Data Guard Broker management of databases in a configuration and the effects of doing this? (Choose three.)

    Show answer details

    Correct answer: B, C, D

    B, C, D -- Reference: https://docs.oracle.eom/cd/B28359 01/server.111/b28295/cli.htm#i1005955

    B, C, D -- Reference: https://docs.oracle.eom/cd/B28359 01/server.111/b28295/cli.htm#i1005955

    B, C, D -- Reference: https://docs.oracle.eom/cd/B28359 01/server.111/b28295/cli.htm#i1005955

  2. 2

    Examine the Data Guard configuration:

    DGMGRL> show configuration;
    Configuration-Animals
    Protection Mode: MaxPerformance
    Databases:
    dogs- Primary database
    sheep- Physical standby database cats- Snapshot standby database
    Fast-Start Failover: DISABLED
    Configuration Status:
    SUCCESS

    You receive an error while attempting to raise the protection mode to Maximum Protection:

    DGMGRL) edit configuration set protection mode as maxprotection;
    Error: ORA-16627: operation disallowed since no standby databases would remain to support protection mode Failed.

    What can you conclude based on this error?

    Show answer details

    Correct answer: B

    Explanation:
    Sheep is the Physical standby database.
    Error cause: The broker rejects an attemptto change the configuration's overall protection mode since it could notfind any online, enabled standby databases that supportthe proposed protection mode.
    Action: If changing the overall protection mode, confirm that at least one standby database satisfies the new protection mode.
    -- Reference: http://psoug.org/oraerror/ORA-16627.htm

  3. 3

    Examine the Data Guard configuration:DGMGRL) show configuration;Configuration - AnimalsProtection Mode: MaxPerformanceDatabases:dogs - Primary databasesheep - Snapshot standby database cats - Snapshot standby databaseFast-Start Failover: DISABLEDConfiguration Status:SUCCESSYou receive an error while attempting to raise the protection mode to Maximum Availability:DGMGDRL) edit configuration set protection mode as maxavailability;Error: ORA-16627: operation disallowed since no standby databases would remain to support protection mode Failed.
    Identify two statements that you can execute, either one of which will enable successful raising of the protection mode to Maximum Availability. (Choose two.)

    Show answer details

    Correct answer: D, E

    D, E

    D, E

  4. 4

    You administer a Data Guard environmentwith a primary and two physical standby databases.

    One of the physical standby databases is used for reporting and is on the same host as the primary database.

    The other physical standby database is remote, used for disaster recovery and REDO is routed to itvia a far sync instance.

    Backups are offloaded to the remote physical standby.

    Which three are true concerning the management of archive logs in this Data Guard configuration? (Ghoose three.)

    Show answer details
  5. 5

    Which four database parameters might be affected by or influence the creation of standby databases? (Choose four.)

    Show answer details

    Correct answer: A, D, E, F

    A, D, E, F -- Explanation:A: DB_NAMEOn a primary database, specify the name used when the database was created. On a physical standby database, use the DB_NAME of the primary database.
    C: Ensure the COMPATIBLE initialization parameter is setto the same value on both the primary and standby databases. if the values differ, redo transport services may be unable to transmit redo data from the primary database to the standby databases.
    D: DB_FILE_NAME_CONVERTSpecify the path name and filename location of the primary database data files followed by the standby location. This parameter converts the path names of the primary database data files to the standby data file path names.
    E: DB_UNIQUE_NAMESpecify a unique name for each database. This name stays with the database and does not change, even if the primary and standby databases reverse roles.
    F: FAL_SERVERSpecify the Oracle Net service name of the FAL server (typically this is the database running in the primary role). -- Reference: https://docs.oracle.eom/database/121/SBYDB/create ps.htm#SBYDB4720

    A, D, E, F -- Explanation:A: DB_NAMEOn a primary database, specify the name used when the database was created. On a physical standby database, use the DB_NAME of the primary database.
    C: Ensure the COMPATIBLE initialization parameter is setto the same value on both the primary and standby databases. if the values differ, redo transport services may be unable to transmit redo data from the primary database to the standby databases.
    D: DB_FILE_NAME_CONVERTSpecify the path name and filename location of the primary database data files followed by the standby location. This parameter converts the path names of the primary database data files to the standby data file path names.
    E: DB_UNIQUE_NAMESpecify a unique name for each database. This name stays with the database and does not change, even if the primary and standby databases reverse roles.
    F: FAL_SERVERSpecify the Oracle Net service name of the FAL server (typically this is the database running in the primary role). -- Reference: https://docs.oracle.eom/database/121/SBYDB/create ps.htm#SBYDB4720

    A, D, E, F -- Explanation:A: DB_NAMEOn a primary database, specify the name used when the database was created. On a physical standby database, use the DB_NAME of the primary database.
    C: Ensure the COMPATIBLE initialization parameter is setto the same value on both the primary and standby databases. if the values differ, redo transport services may be unable to transmit redo data from the primary database to the standby databases.
    D: DB_FILE_NAME_CONVERTSpecify the path name and filename location of the primary database data files followed by the standby location. This parameter converts the path names of the primary database data files to the standby data file path names.
    E: DB_UNIQUE_NAMESpecify a unique name for each database. This name stays with the database and does not change, even if the primary and standby databases reverse roles.
    F: FAL_SERVERSpecify the Oracle Net service name of the FAL server (typically this is the database running in the primary role). -- Reference: https://docs.oracle.eom/database/121/SBYDB/create ps.htm#SBYDB4720

    A, D, E, F -- Explanation:A: DB_NAMEOn a primary database, specify the name used when the database was created. On a physical standby database, use the DB_NAME of the primary database.
    C: Ensure the COMPATIBLE initialization parameter is setto the same value on both the primary and standby databases. if the values differ, redo transport services may be unable to transmit redo data from the primary database to the standby databases.
    D: DB_FILE_NAME_CONVERTSpecify the path name and filename location of the primary database data files followed by the standby location. This parameter converts the path names of the primary database data files to the standby data file path names.
    E: DB_UNIQUE_NAMESpecify a unique name for each database. This name stays with the database and does not change, even if the primary and standby databases reverse roles.
    F: FAL_SERVERSpecify the Oracle Net service name of the FAL server (typically this is the database running in the primary role). -- Reference: https://docs.oracle.eom/database/121/SBYDB/create ps.htm#SBYDB4720

  6. 6

    Which three are prerequisites for enabling Fast-Start Failover? (Choose three.)

    Show answer details

    Correct answer: B, D, F

    B, D, F -- Explanation:
    B: You enable the Flashback Mode both on the primary database and on the standby database.
    D: In Maximum Availability mode, Fast-Start Failover (FSFO) guarantees that no transaction that has received a commit acknowledgment will be lost during a failover. Oracle Database 11g FSFO adds support for Maximum Performance mode (async redo transfer), providing the flexibility to trade durability for performance.
    F: The Dataguard Broker Observer (Observer) is used when fast start failover is required. Fast start failover is simply an automatic failover to the standby database
    Incorrect answers:
    C: You enable the Flashback Mode both on the primary database and on the standby database.
    References: http://dbasoumya.blogspot.se/2015/07/fast-start-failoverfsfo-in-oracle-11g.html
    http://www.oracle.com/technetwork/articles/smiley-fsfo-084973.html

    B, D, F -- Explanation:
    B: You enable the Flashback Mode both on the primary database and on the standby database.
    D: In Maximum Availability mode, Fast-Start Failover (FSFO) guarantees that no transaction that has received a commit acknowledgment will be lost during a failover. Oracle Database 11g FSFO adds support for Maximum Performance mode (async redo transfer), providing the flexibility to trade durability for performance.
    F: The Dataguard Broker Observer (Observer) is used when fast start failover is required. Fast start failover is simply an automatic failover to the standby database
    Incorrect answers:
    C: You enable the Flashback Mode both on the primary database and on the standby database.
    References: http://dbasoumya.blogspot.se/2015/07/fast-start-failoverfsfo-in-oracle-11g.html
    http://www.oracle.com/technetwork/articles/smiley-fsfo-084973.html

    B, D, F -- Explanation:
    B: You enable the Flashback Mode both on the primary database and on the standby database.
    D: In Maximum Availability mode, Fast-Start Failover (FSFO) guarantees that no transaction that has received a commit acknowledgment will be lost during a failover. Oracle Database 11g FSFO adds support for Maximum Performance mode (async redo transfer), providing the flexibility to trade durability for performance.
    F: The Dataguard Broker Observer (Observer) is used when fast start failover is required. Fast start failover is simply an automatic failover to the standby database
    Incorrect answers:
    C: You enable the Flashback Mode both on the primary database and on the standby database.
    References: http://dbasoumya.blogspot.se/2015/07/fast-start-failoverfsfo-in-oracle-11g.html
    http://www.oracle.com/technetwork/articles/smiley-fsfo-084973.html

Create an account to continue.